Subject: RARE user and assistance email list
List archive
[RARE-users] [freertr] Unable to get GNS3 NAT cloud working with freertr (looks like misconfiguration of my freerouter node)
Chronological Thread
- From: "Arvind P" <>
- To:
- Subject: [RARE-users] [freertr] Unable to get GNS3 NAT cloud working with freertr (looks like misconfiguration of my freerouter node)
- Date: Sun, 09 Jul 2023 19:55:53 -0700
- List-id: <freertr.groups.io>
- Mailing-list: list ; contact
I've tried my level best to figure this out myself but I am getting stumped.
In the network topology from GNS3
1) NAT1/NAT2 are the same thing. On my linux host system its configuration is:
<name>default</name>
<uuid>6eefc8b6-655b-4b6f-9618-ee1371365ab8</uuid>
<forward mode='nat'>
<nat>
<port start='1024' end='65535'/>
</nat>
</forward>
<bridge name='virbr0' stp='on' delay='0'/>
<mac address='52:54:00:22:0e:f3'/>
<ip address='192.168.122.1' netmask='255.255.255.0'>
<dhcp>
<range start='192.168.122.100' end='192.168.122.254'/>
<host mac='52:54:00:4d:0f:07' name='winServer22' ip='192.168.122.10'/>
<host mac='52:54:00:6e:5c:6a' name='win10' ip='192.168.122.11'/>
</dhcp>
</ip>
</network>
so its a NAT + dhcp server.
2) FR-4 is the freerouter node for which I am trying to troubleshoot giving nodes access to the internet via the NAT1. Below is its configuration:
hostname FR-4
buggy
!
!
vrf definition host
exit
!
vrf definition v1
rd 1:1
exit
!
interface ethernet1
vrf forwarding v1
ipv4 address 172.16.1.1 255.255.255.0
no shutdown
no log-link-change
exit
!
interface ethernet2
vrf forwarding v1
ipv4 address 192.168.1.1 255.255.255.0
no shutdown
no log-link-change
exit
!
interface ethernet20001
vrf forwarding host
ipv4 address 10.255.255.254 255.255.255.0
no shutdown
no log-link-change
exit
!
interface ethernet3
vrf forwarding v1
ipv4 address 192.168.122.247 255.255.255.0
ipv4 dhcp-client enable
no shutdown
no log-link-change
exit
!
interface ethernet4
no shutdown
no log-link-change
exit
!
interface ethernet5
no shutdown
no log-link-change
exit
!
interface ethernet6
no shutdown
no log-link-change
exit
!
console0
no exec authorization
no login authentication
exit
!
line tty1
no exec authorization
no login authentication
exit
!
!
!
ipv4 route v1 0.0.0.0 255.255.255.255 192.168.122.1
ipv4 route v1 192.168.0.0 255.255.255.0 192.168.122.1
!
!
server telnet host
security protocol telnet
no exec authorization
no login authentication
vrf host
exit
!
3) FR-3 is a freerouter node which is not relevant to my question.
4) FR-1, FR-2 are also irrelevant to the question.
Below is the output of the command `sh ipv4 route v1'
typ prefix metric iface hop time
S 0.0.0.0/32 1/0 ethernet3 192.168.122.1 00:23:24
C 172.16.1.0/24 0/0 ethernet1 null 00:23:34
LOC 172.16.1.1/32 0/1 ethernet1 null 00:23:34
S 192.168.0.0/24 1/0 ethernet3 192.168.122.1 00:23:24
C 192.168.1.0/24 0/0 ethernet2 null 00:23:34
LOC 192.168.1.1/32 0/1 ethernet2 null 00:23:34
C 192.168.122.0/24 0/0 ethernet3 null 00:23:24
REM 192.168.122.1/32 0/0 ethernet3 192.168.122.1 00:23:24
LOC 192.168.122.247/32 0/1 ethernet3 null 00:23:24
Observations:
- Alpine 3.16.2 directly connected to NAT gets a random DHCP address and can ping nodes on my LAN and reach outside to google etc. like the host.
- Alpine 3.16.1 connected through FR-4 can ping 172.16.1.2 (Interface of FR-3), ping 192.168.0.1 (and other alive nodes on the LAN) after adding the static route to 192.168.0.0/24 manually but not with the static route to 0.0.0.0/32 alone
- FR-4 can ping the LAN nodes through the NAT with the above config but cannot resolve google.com or any public ip address. Since Apline 3.16.2 can ping google.com successfully. There is some problem with my configuration.
- My LAN is on the 192.168.0.0/24 network with ip 192.168.0.1 and this is connected through WAN to my ISP who provides internt services.
Can you please guide me on what I am doing wrong.
Here is some output of my troubleshooting:
FR-4(cfg)#sh ipv4 route v1
typ prefix metric iface hop time
C 172.16.1.0/24 0/0 ethernet1 null 00:35:28
LOC 172.16.1.1/32 0/1 ethernet1 null 00:35:28
S 192.168.0.0/24 1/0 ethernet3 192.168.122.1 00:35:18
C 192.168.1.0/24 0/0 ethernet2 null 00:35:28
LOC 192.168.1.1/32 0/1 ethernet2 null 00:35:28
C 192.168.122.0/24 0/0 ethernet3 null 00:35:18
REM 192.168.122.1/32 0/0 ethernet3 192.168.122.1 00:35:18
LOC 192.168.122.247/32 0/1 ethernet3 null 00:35:18
FR-4(cfg)#ping 192.168.0.1
invalid command, try ?
FR-4(cfg)#ping 192.168.0.1 vrf v1
invalid command, try ?
FR-4(cfg)#do ping 192.168.0.1 vrf v1
pinging 192.168.0.1, src="null," vrf=v1, cnt=5, len=64, df=false, tim=1000, gap=0, ttl=255, tos=0, sgt=0, flow=0, fill=0, alrt=-1, sweep=false, multi=false
!!!!!
result=100.0%, recv/sent/lost/err=5/5/0/0, took 79, min/avg/max/dev rtt=3/15.2/60/502, ttl 63/63.0/63/0.0, tos 0/0.0/0/0.0
FR-4(cfg)#
Observation: Can ping gateway of main router but not access internet through router.
Please help me figure out what I am doing wrong.
_._,_._,_
Groups.io Links:
You receive all messages sent to this group.
View/Reply Online (#1725) |
|
|
Mute This Topic
| New Topic
Your Subscription |
|
Unsubscribe
[]
_._,_._,_
- [RARE-users] [freertr] Unable to get GNS3 NAT cloud working with freertr (looks like misconfiguration of my freerouter node), Arvind P, 07/10/2023
Archive powered by MHonArc 2.6.24.