Skip to Content.
Sympa Menu

rare-users - Re: [RARE-users] Interface debugging

Subject: RARE user and assistance email list

List archive

Re: [RARE-users] Interface debugging


Chronological Thread 
  • From: Xavier Jeannin <>
  • To:
  • Subject: Re: [RARE-users] Interface debugging
  • Date: Wed, 23 Feb 2022 13:45:13 +0100
  • Dkim-filter: OpenDKIM Filter v2.10.3 zmtaauth02.partage.renater.fr 3DBF5A0105

Sorry Frédéric, but as you explained already I knew that the

DAV0001@sdn7 should be in bridge 1
DAV0001@sdn15 should be in bridge 1

But My problem was that interface on  DAV0102 @ sdn5 was down, I was not able to bring it UP.

So I see it is now UP and you also change the IP@, can you explain me how you put it UP? Reload ?

Regards
Xavier

Le 23/02/2022 à 13:40, Frédéric LOUI a écrit :
Thanks for the traces,

You want to achieve:
DAV0101 @sdn5 <--------> @ sdn7-DAV0001-@sdn15 <--------> DAV0102 @ sdn5

- WEDGE100BF32X is acting as a bridge (bridge 1) between DAV0101@sdb5 and DAV0102@sdn5
- DAV0101 @sdn5
- DAV0102 @sdn5

So:
DAV0001@sdn7 should be in bridge 1
DAV0001@sdn15 should be in bridge 1


In your output below:

DAV0001@sdn7: 
description frontpanel port 7/0
vrf forwarding net
ipv4 address 1.1.1.1 255.255.255.0
exit

DAV0001@sdn15: 
interface sdn15
 description frontpanel port 15/0
 vrf forwarding inet
 ipv4 address 1.1.2.1 255.255.255.0
 exit

We need to put them into bridge-group

Also:
DAV0101@sdn5 is not in the same subnet as DAV0102@sdn5

DAV0101@ sdn5                                                                                                            
interface sdn5
 vrf forwarding inet
 ipv4 address 1.1.1.3 255.255.255.0

DAV0102@sdn5
interface sdn5
vrf forwarding inet
ipv4 address 1.1.2.2 255.255.255.0

As we want to bridge and not route this is what I’ve done:

DAV0101@ sdn5                                                                                                            
DAV0101#conf t                                                                                                                 
DAV0101(cfg)#interface sdn5                                                                                                    
DAV0101(cfg-if)#ipv4 address 11.11.11.3 /24         

DAV0102@ sdn5                                                                                                            
DAV0102#conf t                                                                                                                 
DAV0102(cfg)#interface sdn5                                                                                                    
DAV0102(cfg-if)#ipv4 address 11.11.11.4 /24    

Now I’m binding the DAV0001 sdn 7 and sdn15 bridge to bridge 1:

DAV0001#conf t                                                                                                                 
DAV0001(cfg)#interface sdn7                                                                                                    
DAV0001(cfg-if)#no vrf forwarding inet                                                                                         
DAV0001(cfg-if)#bridge-group 1                                                                                                 
DAV0001(cfg-if)#exit                                                                                                           
DAV0001(cfg)#int sdn15                                                                                                         
DAV0001(cfg-if)#no vrf forwarding inet                                                                                         
DAV0001(cfg-if)#bridge-group 1                                                                                                 
DAV0001(cfg-if)#end                                                                                                            

DAV0001#sh run sdn7                                                                                                                                                                                                                                           
interface sdn7
 description frontpanel port 7/0
 mtu 1500
 macaddr 0040.784a.0b38
 lldp enable
 bridge-group 1
 no shutdown
 log-link-change
 exit

DAV0001#sh run sdn15                                                                                                                                                                                                                                          
interface sdn15
 description frontpanel port 15/0
 mtu 1500
 macaddr 0056.2158.6249
 lldp enable
 bridge-group 1
 no shutdown
 log-link-change
 exit

Verification:

DAV0102#sh run sdn5                                                                                                                                                                                                                                           
interface sdn5
 description 10G-FP2[eno7 - 05:00.1 - 18:5a:58:d8:d4:65]
 mtu 1500
 macaddr 0014.0b0d.536c
 lldp enable
 vrf forwarding inet
 ipv4 address 11.11.11.4 255.255.255.0
 no shutdown
 no log-link-change
 exit

DAV0102#sh ipv4 arp sdn5                                                                                                                                                                                                                                      
mac             address     time      static
0060.1a21.1d27  11.11.11.3  00:00:46  false

DAV0102#ping 11.11.11.3 /vrf inet                                                                                                                                                                                                                             
pinging 11.11.11.3, src="null," vrf=inet, cnt=5, len=64, tim=1000, gap=0, ttl=255, tos=0, flow=0, fill=0, sweep=false, multi=false, detail=false
!!!!!
result=100%, recv/sent/lost/err=5/5/0/0, rtt min/avg/max/sum=0/0/1/4, ttl min/avg/max=254/254/254
DAV0102#                                                                     

DAV0102#sh run sdn5                                                           
interface sdn5
 description 10G-FP2[eno7 - 05:00.1 - 18:5a:58:d8:d4:65]
 mtu 1500
 macaddr 0014.0b0d.536c
 lldp enable
 vrf forwarding inet
 ipv4 address 11.11.11.4 255.255.255.0
 no shutdown
 no log-link-change
 exit

DAV0102#sh ipv4 arp sdn5                                                      
mac             address     time      static
0060.1a21.1d27  11.11.11.3  00:00:23  false

DAV0102#ping 11.11.11.3 /vrf inet /repeat 1000                                
pinging 11.11.11.3, src="null," vrf=inet, cnt=1000, len=64, tim=1000, gap=0, ttl=255, tos=0, flow=0, fill=0, sweep=false, multi=false, detail=false
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
result=100%, recv/sent/lost/err=1000/1000/0/0, rtt min/avg/max/sum=0/0/13/742, ttl min/avg/max=254/254/254
DAV0102#                                                                      

Check bridge counters:

DAV0001#show bridge 1                                                                                                                                                                                                                                         
                   packet          byte
iface  fwd   phys  tx   rx   drop  tx     rx     drop  grp
bvi    true  true  0    0    0     0      0      0
sdn7   true  true  4    133  0     192    10196  0
sdn15  true  true  131  4    0     10032  192    0

                               packet                      byte
addr            iface  static  time      tx      rx        drop  tx        rx            drop
0014.0b0d.536c  sdn15  false   00:00:05  0+2152  4+2173    0+0   0+155912  192+164400    0+0
0060.1a21.1d27  sdn7   false   00:00:05  0+2150  133+2260  0+0   0+161548  10196+167288  0+0

I hope this helps,
fl

Le 23 févr. 2022 à 11:44, Xavier JEANNIN  a écrit :

Hello Frédéric 

thank you for your help, my answer is inline
I try to put anything 


for 6666, this is a typo and the problem occur between    DAV 0001 wedge  <---> DAV 0102 DPDK - VEP
So I come back to very simple connection between 2 IPv4 interfaces : DAV 0001 wedge (sdn15 [up] 1.1.2.1) <---> DAV 0102 DPDK - VEP (sdn5 [down]  1.1.2.2) 


DAV0001#show ipv4 interface
interface     state  address    netmask
loopback0     up     10.1.1.1   255.255.255.255
loopback1234  up     1.2.3.4    255.255.255.255
ethernet1     up     0.0.0.0    255.255.255.255
sdn10         up     10.1.12.1  255.255.255.0
sdn15         up     1.1.2.1    255.255.255.0
sdn7          up     1.1.1.1    255.255.255.0
sdn7.666      up     6.6.6.1    255.255.255.0


DAV0102#show ipv4 interface
interface     state  address    netmask
loopback0     up     10.1.4.4   255.255.255.255
loopback1     up     2.2.2.4    255.255.255.255
loopback4444  up     4.4.4.4    255.255.255.255
sdn1          up     10.1.34.4  255.255.255.0
sdn2          up     10.2.34.4  255.255.255.0
sdn3          up     10.3.34.4  255.255.255.0
sdn4          admin  10.1.24.4  255.255.255.0
sdn5          down   1.1.2.2    255.255.255.0
sdn6          up     10.6.34.4  255.255.255.0
sdn7          up     10.7.34.4  255.255.255.0

lldp shows that the DAV0001 does not see the DAV0102
DAV0001#show lldp neighbor
interface  hostname  iface     ipv4       ipv6
sdn10      DAV0021   sdn17     10.1.12.2  null
sdn7       DAV0101   sdn5      1.1.1.3    1234:1::3
sdn7.666   DAV0101   sdn5.666  6.6.6.3    fd00::6:6:6:3

and lldp shows that the DAV0102 cannot see any other routers even if it is activated
DAV0102#show lldp neighbor
interface  hostname  iface  ipv4  ipv6


DAV0001#show running-config hide
hostname DAV0001
buggy
!
logging buffered debug 10240
logging file debug /var/log/freertr.log
logging rotate 655360000 /var/log/freertr.old
!
crypto rsakey rsa import $w10$<removed>$
!
crypto dsakey dsa import $w10$<removed>$
!
crypto ecdsakey ecdsa import $w10$<removed>$
!
aaa userlist usr
username rare
username rare password $w10$<removed>$
exit
!
scheduler errors
time 600000
delay 30000
command clear errors 
start
exit
!
access-list ACL_IN_4
sequence 10 permit all any all any all
exit
!
access-list ACL_IN_6
sequence 10 permit all any all any all
exit
!
access-list ACL_NAT4
sequence 10 permit 17 any all 4.4.4.4 255.255.255.255 all
sequence 20 permit 6 any all 4.4.4.4 255.255.255.255 all
sequence 30 deny all any all any all
exit
!
access-list ACL_NAT6
sequence 10 permit 17 any all fd00::4:4:4:4 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff all
sequence 20 permit 6 any all fd00::4:4:4:4 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff all
exit
!
access-list test4
sequence 10 permit 1 any all any all
exit
!
access-list test6
sequence 10 permit 58 any all any all
exit
!
prefix-list all4
sequence 10 permit 0.0.0.0/0 ge 0 le 0
exit
!
prefix-list all6
sequence 10 permit ::/0 ge 0 le 0
exit
!
bridge 1
mac-learn
exit
!
vrf definition inet
exit
!
vrf definition isisvrf
exit
!
vrf definition lin
exit
!
vrf definition oob
exit
!
vrf definition p4
description P4 VRF _NEVER_EVER_ CONFIGURE IT
exit
!
router ospf4 1
vrf inet
router-id 10.1.1.1
traffeng-id 0.0.0.0
area 0 enable
exit
!
router ospf6 1
vrf inet
router-id 10.1.1.1
traffeng-id ::
area 0 enable
exit
!
interface loopback0
no description
vrf forwarding inet
ipv4 address 10.1.1.1 255.255.255.255
router ospf4 1 enable
router ospf4 1 area 0
router ospf4 1 passive
no shutdown
no log-link-change
exit
!
interface loopback1234
no description
vrf forwarding inet
ipv4 address 1.2.3.4 255.255.255.255
no shutdown
no log-link-change
exit
!
interface bvi1
no description
no shutdown
no log-link-change
exit
!
interface ethernet0
description CPU_PORT _NEVER_EVER_ CONFIGURE IT
no shutdown
no log-link-change
exit
!
interface ethernet1
description out of band management port
vrf forwarding oob
ipv4 address dynamic dynamic
ipv4 gateway-prefix all4
ipv4 dhcp-client enable
ipv4 dhcp-client early
ipv6 address dynamic dynamic
ipv6 gateway-prefix all6
ipv6 slaac
ipv6 prefix-suppress
no shutdown
no log-link-change
exit
!
interface sdn10
description frontpanel port 10/0
mtu 1500
macaddr 0031.755e.0363
lldp enable
vrf forwarding inet
ipv4 address 10.1.12.1 255.255.255.0
router ospf4 1 enable
router ospf4 1 area 0
router ospf4 1 cost 10000
no shutdown
no log-link-change
exit
!
interface sdn15
description frontpanel port 15/0
mtu 1500
macaddr 0056.2158.6249
lldp enable
vrf forwarding inet
ipv4 address 1.1.2.1 255.255.255.0
ipv6 address 1234:2::1 ffff:ffff::
router ospf4 1 enable
router ospf4 1 area 0
router ospf6 1 enable
router ospf6 1 area 0
no shutdown
log-link-change
exit
!
interface sdn5
no description
mtu 1500
macaddr 0059.6603.523d
no shutdown
no log-link-change
exit
!
interface sdn7
description frontpanel port 7/0
mtu 1500
macaddr 0040.784a.0b38
lldp enable
vrf forwarding inet
ipv4 address 1.1.1.1 255.255.255.0
ipv4 inspect allow-list test4
ipv6 address 1234:1::1 ffff:ffff::
ipv6 inspect allow-list test6
router ospf4 1 enable
router ospf4 1 area 0
router ospf6 1 enable
router ospf6 1 area 0
no shutdown
log-link-change
exit
!
interface sdn7.666
no description
lldp enable
vrf forwarding inet
ipv4 address 6.6.6.1 255.255.255.0
no shutdown
no log-link-change
exit
!
router bgp4 666
vrf isisvrf
local-as 1213
router-id 87.44.48.238
address-family linkstate
exit
!
proxy-profile oob
vrf oob
exit
!
!
ipv4 route inet 2.2.2.2 255.255.255.255 10.1.13.3
ipv4 route inet 3.3.3.3 255.255.255.255 10.1.13.3
ipv4 route inet 6.6.6.6 255.255.255.255 10.1.13.3
!
!
!
!
ipv4 nat inet sequence 10 srclist ACL_NAT4 interface sdn15
!
ipv6 nat inet sequence 10 srclist ACL_NAT6 interface sdn15
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
alias test tna-asic-temp command attach shell1 /opt/freertr/bin/sh_tna_temp.sh
alias test tna-asic-temp cmd2nd flash type /etc/freertr/tna_temp.cfg
alias test tna-asic-temp description display forwarding asic cpu temperature
!
alias test tna-linux-access command ssh 10.255.255.1 /vrf lin /user sysadmin /pass sysadmin
alias test tna-linux-access description access linux console
!
alias test tna-linux-temp command attach shell2 acpi -V
alias test tna-linux-temp description display main cpu temperature
!
alias test tna-port-detect command attach shell1 /opt/freertr/bin/sh_tna_ports.sh
alias test tna-port-detect cmd2nd test hwpop uclipm /etc/freertr/tna_ports.cfg server p4lang p4 ports ready auto normal apply add
alias test tna-port-detect description Detect TOFINO ports
!
alias test tna-port-remove command attach shell1 /opt/freertr/bin/sh_tna_ports.sh
alias test tna-port-remove cmd2nd test hwpop uclipm /etc/freertr/tna_ports.cfg server p4lang p4 ports ready auto normal apply del
alias test tna-port-remove description Remove NON RDY TOFINO ports
!
server telnet oob
security authentication usr
security rsakey rsa
security dsakey dsa
security ecdsakey ecdsa
second-port 22
exec logging
no exec authorization
login authentication usr
login logging
vrf oob
exit
!
server telnet p4
security protocol telnet
exec logging
no exec authorization
no login authentication
login logging
vrf p4
exit
!
server p4lang p4
export-vrf inet 1
export-bridge 1
export-port sdn15 12 10 0 0 0
export-port sdn10 52 10 0 0 0
export-port sdn7 176 10 0 0 0
export-port sdn7.666 666 10 0 0 0
interconnect ethernet0
vrf p4
exit
!
client proxy oob
client name-server 1.1.1.1
client time-server europe.pool.ntp.org
client time-zone CET
!
end




DAV0102#show running-config hide
hostname DAV0102
buggy
!
logging buffered debug 8192
logging file debug zzz.log
logging rotate 65536000 zzz.old
!
crypto rsakey rsa import $w10$<removed>$
!
crypto dsakey dsa import $w10$<removed>$
!
crypto ecdsakey ecdsa import $w10$<removed>$
!
aaa userlist users
username *
username * anypass
username rare
username rare password $w10$<removed>$
exit
!
scheduler errors
time 600000
delay 30000
command clear errors 
start
exit
!
scheduler upgrade
time 600000
delay 60000
random-time 60000
random-delay 300000
command flash upgrade
start
exit
!
object-group network host4
sequence 10 10.255.255.0 255.255.255.0
exit
!
object-group network host6
sequence 10 2001:db8:ffff:ffff:: ffff:ffff:ffff:ffff::
exit
!
object-group network lloc4
sequence 10 169.254.0.0 255.255.0.0
exit
!
object-group network lloc6
sequence 10 fe80:: ffff::
exit
!
object-group network mcast4
sequence 10 224.0.0.0 255.255.0.0
exit
!
object-group network mcast6
sequence 10 ff00:: ff00::
exit
!
access-list nat4
sequence 10 deny all obj lloc4 all any all
sequence 20 deny all any all obj mcast4 all
sequence 30 deny all obj host4 all obj host4 all
sequence 40 permit all obj host4 all any all
exit
!
access-list nat6
sequence 10 deny all obj lloc6 all any all
sequence 20 deny all any all obj mcast6 all
sequence 30 deny all obj host6 all obj host6 all
sequence 40 permit all obj host6 all any all
exit
!
prefix-list all4
sequence 10 permit 0.0.0.0/0 ge 0 le 0
exit
!
prefix-list all6
sequence 10 permit ::/0 ge 0 le 0
exit
!
vrf definition inet
exit
!
vrf definition p4
exit
!
router ospf4 1
vrf inet
router-id 10.1.4.4
traffeng-id 0.0.0.0
area 0 enable
exit
!
router ospf6 1
vrf inet
router-id 10.1.4.4
traffeng-id ::
area 0 enable
exit
!
interface loopback0
no description
vrf forwarding inet
ipv4 address 10.1.4.4 255.255.255.255
router ospf4 1 enable
router ospf4 1 area 0
router ospf4 1 passive
no shutdown
no log-link-change
exit
!
interface loopback1
no description
vrf forwarding inet
ipv4 address 2.2.2.4 255.255.255.255
ipv6 address 4321::4 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
router ospf4 1 enable
router ospf4 1 area 0
router ospf4 1 passive
router ospf6 1 enable
router ospf6 1 area 0
router ospf6 1 passive
no shutdown
no log-link-change
exit
!
interface loopback4444
no description
vrf forwarding inet
ipv4 address 4.4.4.4 255.255.255.255
router ospf4 1 enable
router ospf4 1 area 0
router ospf4 1 passive
no shutdown
no log-link-change
exit
!
interface loopback6666
no description
vrf forwarding inet
ipv6 address fd00::4:4:4:4 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
router ospf6 1 enable
router ospf6 1 area 0
router ospf6 1 passive
no shutdown
no log-link-change
exit
!
interface ethernet0
description p4 cpu port
no shutdown
no log-link-change
exit
!
interface sdn1
description FP3[eno3 - 02:00.0 - 18:5a:58:d8:d4:60]
mtu 1500
macaddr 0019.4e1a.2668
lldp enable
vrf forwarding inet
ipv4 address 10.1.34.4 255.255.255.0
no shutdown
no log-link-change
exit
!
interface sdn2
description FP4[eno4 - 02:00.1 - 18:5a:58:d8:d4:61]
mtu 1500
macaddr 005a.0c2f.7412
lldp enable
vrf forwarding inet
ipv4 address 10.2.34.4 255.255.255.0
no shutdown
no log-link-change
exit
!
interface sdn3
description FP1[eno1 - 02:00.2 - 18:5a:58:d8:d4:62]
mtu 1500
macaddr 185a.58d8.d462
lldp enable
vrf forwarding inet
ipv4 address 10.3.34.4 255.255.255.0
no shutdown
no log-link-change
exit
!
interface sdn4
description 10G-FP1[eno8 - 05:00.0 - 18:5a:58:d8:d4:64]
mtu 1500
macaddr 000e.1d31.067c
lldp enable
vrf forwarding inet
ipv4 address 10.1.24.4 255.255.255.0
router ospf4 1 enable
router ospf4 1 area 0
shutdown
no log-link-change
exit
!
interface sdn5
description 10G-FP2[eno7 - 05:00.1 - 18:5a:58:d8:d4:65]
mtu 1500
macaddr 0014.0b0d.536c
lldp enable
vrf forwarding inet
ipv4 address 1.1.2.2 255.255.255.0
no shutdown
no log-link-change
exit
!
interface sdn6
description FP6[eno6 - 07:00.0 - 18:5a:58:d8:d4:66]
mtu 1500
macaddr 0032.380d.1e76
lldp enable
vrf forwarding inet
ipv4 address 10.6.34.4 255.255.255.0
no shutdown
no log-link-change
exit
!
interface sdn7
description FP5[eno5 - 07:00.1]
mtu 1500
macaddr 003d.0919.4168
lldp enable
vrf forwarding inet
ipv4 address 10.7.34.4 255.255.255.0
no shutdown
no log-link-change
exit
!
proxy-profile inet
vrf inet
exit
!
!
!
!
!
!
ipv4 nat inet sequence 10 srclist nat4 interface sdn3
!
ipv6 nat inet sequence 10 srclist nat6 interface sdn3
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
alias test bash command attach shell1 socat - exec:bash,ctty,pty,stderr
alias test bash description get linux shell
!
server telnet p4
security protocol telnet
no exec authorization
no login authentication
vrf p4
exit
!
server telnet tel
security authentication users
security rsakey rsa
security dsakey dsa
security ecdsakey ecdsa
access-log
access-rate 5 5000
access-total 5
access-peer 5
second-port 22
exec logging
no exec authorization
login authentication users
login logging
login last global
vrf inet
exit
!
server p4lang p4
export-vrf inet 1
export-port sdn1 0 1 0 0 0
export-port sdn2 1 1 0 0 0
export-port sdn3 2 1 0 0 0
export-port sdn4 3 10 0 0 0
export-port sdn5 4 10 0 0 0
export-port sdn6 5 1 0 0 0
export-port sdn7 6 1 0 0 0
interconnect ethernet0
vrf p4
exit
!
server dns ns
recursion enable
vrf inet
exit
!
client proxy inet
client name-server 193.49.159.2
client upgrade-server http://upgrade.nop.hu/
client upgrade-backup
client config-backup
client time-server europe.pool.ntp.org
client time-zone CET
!
end





----- Mail original -----
De: "frederic loui" 
À: "rare-users" 
Envoyé: Mercredi 23 Février 2022 09:54:52
Objet: Re: [RARE-users] Interface debugging

Not sure this is a typo but dav0001 has sdn7.6666 (=VLAN 6666)
While the other interface have 666.





Maybe you can with plain interface without VLAN.

Some useful commands:
show ipv4 arp <intf> -> in order to check L2 operation
show ipv6 nei <intf> -> in order to check L2 operation
show lldp nei (granted that lldp is enabled)
ping /repeat <x> /time 11 used with debug ipv4 icmp / term mon in order to check if packet are received (echo request) 
On the other end and if you have response. (Echo reply)

Can you send us config with: show running-config hide ?
(In order to share private key and password) not a big deal it was the opportunity to demonstrate this command.

Le 23 févr. 2022 à 09:44, Xavier Jeannin  a écrit :

Dear All, 

I tried to implement a simple switch layer 2 based on a Wedge.on the  schema attached you can see that the Wedge is connected to 2 DPDK- Dell Machines also running RARE-FreeRtr

In the different step off the configuration, on interface of DPDK- Dell Machines went down and it is impossible to bring it up. 
I use basic command to debug this. 

As beginner, I would like to have advise on which things I have to check ? 
Which commands are useful ? 
How to check how RARE-FreeRtr see the SFP ? any physical parameters  that I can check?
I recall that there is also a correspondence between the port in RARE-FreeRtr and DPDK at system level (if I am not wrong) ?

Thank you
Xavier


<Kh04Rn8q4NBxYMPL.png>

-- 
Xavier JEANNIN
Network Dpt. - Innovation manager
GN4-3 Network technology evolution (WP6 T1) task leader
Tél. : +33 1 5394 2042
Mob. : +33 6 3017 0963

www.renater.fr

    
    
-- 
Xavier JEANNIN
Network Dpt. - Innovation manager
GN4-3 Network technology evolution (WP6 T1) task leader
Tél. : +33 1 5394 2042
Mob. : +33 6 3017 0963
www.renater.fr



Archive powered by MHonArc 2.6.19.

Top of Page