Skip to Content.

rare-dev - Re: [rare-dev] https://www.ietf.org/archive/id/draft-ietf-idr-bgp-ct-00.html#name-co-authors

Subject: Rare project developers

List archive


Re: [rare-dev] https://www.ietf.org/archive/id/draft-ietf-idr-bgp-ct-00.html#name-co-authors


Chronological Thread 
  • From: mc36 <>
  • To: Kaliraj Vairavakkalai <>, Natrajan Venkataraman <>
  • Cc: "" <>
  • Subject: Re: [rare-dev] https://www.ietf.org/archive/id/draft-ietf-idr-bgp-ct-00.html#name-co-authors
  • Date: Thu, 22 Dec 2022 13:33:08 +0100

having the color exteneded community was also easy too:
https://github.com/rare-freertr/freeRtr/commit/06032dfb1a787356f8d74688b1295186f8d9af9e
at this time the import happens by it... so for now, the import/export
happens by color...
and one can have more import colors per vrf so i have the backup color
functionality too... :)
br,
cs


sid#show config-differences
vrf definition v5
clr4import 1234
clr4export 1234
clr6import 1234
clr6export 1234
exit
vrf definition v4
clr4import 1234
clr4export 1234
clr6import 1234
clr6export 1234
exit
hairpin 1
exit
interface loopback4
vrf forwarding v4
ipv4 address 2.2.2.2 255.255.255.255
no shutdown
no log-link-change
exit
interface loopback5
vrf forwarding v5
ipv4 address 2.2.2.3 255.255.255.255
no shutdown
no log-link-change
exit
interface hairpin11
vrf forwarding v2
ipv4 address 1.1.1.1 255.255.255.252
mpls enable
no shutdown
no log-link-change
exit
interface hairpin12
vrf forwarding v3
ipv4 address 1.1.1.2 255.255.255.252
mpls enable
no shutdown
no log-link-change
exit
router bgp4 2
vrf v2
local-as 1
router-id 1.1.1.1
address-family ctp
neighbor 1.1.1.2 remote-as 2
neighbor 1.1.1.2 local-as 1
neighbor 1.1.1.2 address-family ctp
neighbor 1.1.1.2 distance 20
neighbor 1.1.1.2 send-community standard extended
afi-ctp v4 enable
afi-ctp v4 redistribute connected
exit
router bgp4 3
vrf v3
local-as 2
router-id 1.1.1.2
address-family ctp
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 local-as 2
neighbor 1.1.1.1 address-family ctp
neighbor 1.1.1.1 distance 20
neighbor 1.1.1.1 send-community standard extended
afi-ctp v5 enable
afi-ctp v5 redistribute connected
exit

sid#show ipv4 route v4
typ prefix metric iface hop time
C 2.2.2.2/32 0/0 loopback4 null 00:00:07
B 2.2.2.3/32 20/0 null@v2:4 1.1.1.2 00:00:05

sid# sid#show ipv4 route v5 2.2.2.2/32
id category value
vrf v5:4
ipver 4
rd 0:0
original rd 1:4
prefix 2.2.2.2/32
prefix network 2.2.2.2
prefix broadcast 2.2.2.2
prefix wildcard ::
prefix netmask ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
nlri n/a
alternates 1
alternate #0 candidate=true best=true
alt0 type bgp4 3
alt0 source 1.1.1.1
alt0 validity 0
alt0 only to customer 0
alt0 segrout index 0
alt0 segrout old base 0
alt0 segrout base 0
alt0 segrout size 0
alt0 segrout offset 0
alt0 segrout prefix null
alt0 bier index 0
alt0 bier old base 0
alt0 bier base 0
alt0 bier range 0
alt0 bier size 0-32
alt0 updated 2022-12-22 13:27:05 (00:00:43 ago)
alt0 version 7
alt0 distance 20
alt0 metric 0
alt0 ident 0
alt0 hops 0
alt0 interface null
alt0 table v3:4
alt0 nexthop 1.1.1.1
alt0 original nexthop null
alt0 tag 0
alt0 origin type 0
alt0 local preference 100
alt0 evpn label*16 0
alt0 attribute as 0
alt0 attribute value n/a
alt0 tunnel type 0
alt0 tunnel value n/a
alt0 link state n/a
alt0 pmsi type 0
alt0 pmsi label*16 0
alt0 pmsi tunnel n/a
alt0 accumulated igp 0
alt0 bandwidth 0
alt0 atomic aggregator false
alt0 aggregator as 0
alt0 aggregator router null
alt0 originator null
alt0 cluster list
alt0 aspath 1
alt0 path length 1
alt0 standard community
alt0 extended community 2:1:4 2562:0:1234
alt0 large community
alt0 internal source 4
alt0 local label 378612
alt0 remote label 20416
counter tx=0(0) rx=0(0) drp=0(0)
lastio input never ago, output never ago, drop never ago
hardware counter null

sid#

On 12/22/22 12:40, mc36 wrote:
hi,
i just prepared a christmas present for you:

rare/freerouter just got colorful vrfs, and it exports and imports from bgp
ctp afi...
tbh it was not too hard at all, i just reused the vrf class afterall... :)
https://github.com/rare-freertr/freeRtr/commit/f0eb1bc325b5a2d1c58d670b22a7fc44d8a29850

i'll add some test cases covering the import/export in a later commit... :)
okk, i also need to be able to parse the color:100 extcomm in the vrf config,
also later...
and yeahh, the backup rt thing is also missing at the moment... :)
and finally, i really need to deal with the flex algo topologies from the
igps... :)

but heyy, if you wish, we could show them an other round of interop on the
next ietf,
and at this time, freerouter could go without the outer ldp label imho... :)
for now, rare/freertr could do an
---[ebgp]----asbr1--[ibgp]---asbr2----[ebgp]---
where you dont need ldp in between the asbr12...
br,
cs


sid#show config-differences
vrf definition v5
no rt6export 1:5
no rt6import 1:5
no rt4export 1:5
no rt4import 1:5
rt4import 1:4
rt4export 1:4
rt6import 1:4
rt6export 1:4
exit
hairpin 1
exit
interface loopback4
vrf forwarding v4
ipv4 address 2.2.2.2 255.255.255.255
no shutdown
no log-link-change
exit
interface loopback5
vrf forwarding v5
ipv4 address 2.2.2.3 255.255.255.255
no shutdown
no log-link-change
exit
interface hairpin11
vrf forwarding v2
ipv4 address 1.1.1.1 255.255.255.252
mpls enable
no shutdown
no log-link-change
exit
interface hairpin12
vrf forwarding v3
ipv4 address 1.1.1.2 255.255.255.252
mpls enable
no shutdown
no log-link-change
exit
router bgp4 2
vrf v2
local-as 1
router-id 1.1.1.1
address-family ctp
neighbor 1.1.1.2 remote-as 2
neighbor 1.1.1.2 local-as 1
neighbor 1.1.1.2 address-family ctp
neighbor 1.1.1.2 distance 20
neighbor 1.1.1.2 send-community standard extended
afi-ctp v4 enable
afi-ctp v4 redistribute connected
exit
router bgp4 3
vrf v3
local-as 2
router-id 1.1.1.2
address-family ctp
neighbor 1.1.1.1 remote-as 1
neighbor 1.1.1.1 local-as 2
neighbor 1.1.1.1 address-family ctp
neighbor 1.1.1.1 distance 20
neighbor 1.1.1.1 send-community standard extended
afi-ctp v5 enable
afi-ctp v5 redistribute connected
exit

sid#
sid#show ipv4 bgp 2 ctp database
prefix hop metric aspath
2.2.2.2/32 1:4 null 0/0/0/0
2.2.2.3/32 1:5 1.1.1.2 20/100/0/0 2

sid#show ipv4 bgp 3 ctp database
prefix hop metric aspath
2.2.2.2/32 1:4 1.1.1.1 20/100/0/0 1
2.2.2.3/32 1:5 null 0/0/0/0

sid#show ipv4 route v4
typ prefix metric iface hop time
C 2.2.2.2/32 0/0 loopback4 null 00:00:16
B 2.2.2.3/32 20/0 null@v2:4 1.1.1.2 00:00:14

sid#show ipv4 route v5
typ prefix metric iface hop time
B 2.2.2.2/32 20/0 null@v3:4 1.1.1.1 00:00:14
C 2.2.2.3/32 0/0 loopback5 null 00:00:17

sid#
sid#ping 2.2.2.3 vrf v4
pinging 2.2.2.3, src=null, vrf=v4, cnt=5, len=64, df=false, tim=1000, gap=0,
ttl=255, tos=0, sgt=0, flow=0, fill=0, alrt=-1, sweep=false, multi=false
!!!!!
result=100.0%, recv/sent/lost/err=5/5/0/0, took 1, min/avg/max/dev
rtt=0/0.1/1/0.1, ttl 255/255/255/0.0, tos 0/0.0/0/0.0
sid#show interfaces hairpin11 ethertypes
packet byte
type value handler tx rx drop tx rx drop
ethtyp 0000 null 0 0 0 0 0 0
ethtyp 0800 ip4 51 48 0 3083 3011 0
ethtyp 0806 arp4 2 2 0 60 60 0
ethtyp 8847 mplsUni 10 10 0 700 700 0
ethtyp 8848 mplsMulti 0 0 0 0 0 0

sid#

On 12/22/22 11:58, mc36 wrote:
hi,
i just noticed some typos in the draft... :)

"
Csaba Mates
Hungarian NREN
"

should be

"
Csaba Mate
KIFU, Hungarian NREN
"

thanks,
cs



Archive powered by MHonArc 2.6.19.

Top of Page