Subject: Rare project developers
List archive
- From: Everson Borges <>
- To:
- Subject: [rare-dev] Doubt about Access-list and PBR
- Date: Thu, 28 Apr 2022 11:00:05 -0300
Hi all,
I made these configurations, however ipv4 works but ipv6 doesn't work and I still haven't found the reason, if someone can help me.
In attached R7 and R5.
access-list polka4
sequence 10 permit 1 7.7.7.0 255.255.255.252 all 20.20.20.6 255.255.255.255 all
exit
!
access-list polka6
sequence 10 permit 1 7777:: ffff:ffff:ffff:ffff:: all 2020::6 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff all
exit
!
sequence 10 permit 1 7.7.7.0 255.255.255.252 all 20.20.20.6 255.255.255.255 all
exit
!
access-list polka6
sequence 10 permit 1 7777:: ffff:ffff:ffff:ffff:: all 2020::6 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff all
exit
!
R7---R5---R1---R3
| |
| |
| |
R6---R2 ---R4
Everson Scherrer Borges
no buggy
!
!
access-list polka4
sequence 10 permit 1 7.7.7.0 255.255.255.252 all 20.20.20.6 255.255.255.255
all
exit
!
access-list polka6
sequence 10 permit 1 7777:: ffff:ffff:ffff:ffff:: all 2020::6
ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff all
exit
!
vrf definition v1
rd 1:1
exit
!
router ospf4 1
vrf v1
router-id 10.5.5.5
traffeng-id 0.0.0.0
segrout 10
area 0 enable
area 0 segrout
redistribute connected
exit
!
router ospf6 1
vrf v1
router-id 10.6.5.5
traffeng-id ::
segrout 10
area 0 enable
area 0 segrout
redistribute connected
exit
!
interface template1
no description
lldp enable
vrf forwarding v1
ipv4 address dynamic dynamic
ipv6 address dynamic dynamic
mpls enable
polka enable 5 65536 10
router ospf4 1 enable
router ospf4 1 area 0
router ospf4 1 segrout index 5
router ospf4 1 segrout node
router ospf6 1 enable
router ospf6 1 area 0
router ospf6 1 segrout index 5
router ospf6 1 segrout node
shutdown
no log-link-change
exit
!
interface loopback0
description lo R5
vrf forwarding v1
ipv4 address 20.20.20.5 255.255.255.255
ipv6 address 2020::5 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
template template1
no shutdown
exit
!
interface ethernet1
description R5 --> R1
vrf forwarding v1
ipv4 address 5.5.5.1 255.255.255.252
ipv6 address 5555::1 ffff:ffff:ffff:ffff::
template template1
no shutdown
exit
!
interface ethernet2
description R5 --> R7
vrf forwarding v1
ipv4 address 7.7.7.2 255.255.255.252
ipv6 address 7777::2 ffff:ffff:ffff:ffff::
template template1
no shutdown
exit
!
interface tunnel1
description POLKA tunnel shortest ipv4 from R5 -> R6
tunnel vrf v1
tunnel source loopback0
tunnel destination 20.20.20.6
tunnel domain-name 20.20.20.1 20.20.20.2
tunnel mode polka
vrf forwarding v1
ipv4 address 30.30.30.1 255.255.255.252
no shutdown
no log-link-change
exit
!
interface tunnel2
description POLKA tunnel longuest ipv4 from R5 -> R6
tunnel vrf v1
tunnel source loopback0
tunnel destination 20.20.20.6
tunnel domain-name 20.20.20.1 20.20.20.4 20.20.20.3 20.20.20.2
tunnel mode polka
vrf forwarding v1
ipv4 address 40.40.40.1 255.255.255.252
no shutdown
no log-link-change
exit
!
interface tunnel3
description POLKA tunnel shortest ipv6 from R5 -> R6
tunnel vrf v1
tunnel source loopback0
tunnel destination 2020::6
tunnel domain-name 2020::1 2020::2
tunnel mode polka
vrf forwarding v1
ipv6 address 3030::1 ffff:ffff:ffff:ffff::
no shutdown
no log-link-change
exit
!
interface tunnel4
description POLKA tunnel longues ipv6 from R5 -> R6
tunnel vrf v1
tunnel source loopback0
tunnel destination 2020::6
tunnel domain-name 2020::1 2020::4 2020::3 2020::2
tunnel mode polka
vrf forwarding v1
ipv6 address 4040::1 ffff:ffff:ffff:ffff::
no shutdown
no log-link-change
exit
!
!
!
!
!
!
!
!
ipv4 pbr v1 sequence 10 polka4 v1 nexthop 40.40.40.2
!
ipv6 pbr v1 sequence 10 polka6 v1 nexthop 4040::2
!
!
!
!
!
server telnet tel
security protocol telnet
exec timeout 10000000
exec colorize prompt
exec logging
no exec authorization
no login authentication
login logging
vrf v1
exit
!
!
end
hostname R7
no buggy
!
!
vrf definition v1
rd 1:1
exit
!
interface template1
no description
lldp enable
vrf forwarding v1
ipv4 address dynamic dynamic
ipv6 address dynamic dynamic
mpls enable
shutdown
no log-link-change
exit
!
interface loopback0
no description
vrf forwarding v1
ipv4 address 20.20.20.7 255.255.255.255
ipv6 address 2020::7 ffff:ffff:ffff:ffff:ffff:ffff:ffff:ffff
template template1
no shutdown
exit
!
interface ethernet1
description R7 --> R5
vrf forwarding v1
ipv4 address 7.7.7.1 255.255.255.252
ipv6 address 7777::1 ffff:ffff:ffff:ffff::
template template1
no shutdown
no log-link-change
exit
!
!
ipv4 route v1 0.0.0.0 0.0.0.0 7.7.7.2
!
ipv6 route v1 :: :: 7777::2
!
!
!
!
!
!
!
!
!
!
!
server telnet tel
security protocol telnet
exec timeout 10000000
exec colorize prompt
exec logging
no exec authorization
no login authentication
login logging
vrf v1
exit
!
!
end
- [rare-dev] Doubt about Access-list and PBR, Everson Borges, 04/28/2022
- Re: [rare-dev] Doubt about Access-list and PBR, mc36, 04/28/2022
- Re: [rare-dev] Doubt about Access-list and PBR, Everson Borges, 04/28/2022
- Re: [rare-dev] Doubt about Access-list and PBR, mc36, 04/28/2022
Archive powered by MHonArc 2.6.19.